PT-2015-4545
CVE-2015-0254
·
Publicado
2015-03-09
·
Atualizado
2026-10-14
Descrição por
CVSS 2.0
7.5
AltaMétricasAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Apache Standard Taglibs versions prior to 1.2.3
Description
The issue allows remote attackers to execute arbitrary code or conduct external XML entity (XXE) attacks. This can be achieved via a crafted XSLT extension in a (1)
<x:parse> or (2) <x:transform> JSTL XML tag.Recommendations
For versions prior to 1.2.3, update to version 1.2.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of
<x:parse> and <x:transform> JSTL XML tags until a patch is applied. Avoid using crafted XSLT extensions in these tags to minimize the risk of exploitation.Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾