PT-2015-5389
CVE-2015-1613
·
Publicado
2015-02-16
·
Atualizado
2015-02-17
Descrição por
CVSS 2.0
4.0
MédiaMétricasAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
RhodeCode versions prior to 2.2.7
Description
The issue allows remote authenticated users to obtain sensitive information, including API keys, by exploiting certain API methods. Specifically, the "update repo", "get locks", and "get user groups" API methods are vulnerable.
Recommendations
For versions prior to 2.2.7, update to version 2.2.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable API methods until a patch is applied. Avoid using the vulnerable API endpoints, such as "update repo", "get locks", and "get user groups", in your applications until the issue is resolved.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾