PT-2015-5682
CVE-2015-2241
·
Publicado
2015-03-12
·
Atualizado
2022-05-17
Descrição por
CVSS 4.0
5.3
MédiaMétricasAV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Name of the Vulnerable Software and Affected Versions
Django versions prior to 1.7.6
Django versions prior to 1.8b2
Description
A cross-site scripting (XSS) issue exists in the contents function in admin/helpers.py, allowing remote attackers to inject arbitrary web script or HTML via a model attribute in
ModelAdmin.readonly fields, as demonstrated by an @property. This enables attackers to execute malicious scripts on the client-side.Recommendations
For Django versions prior to 1.7.6, update to version 1.7.6 or later to resolve the issue.
For Django versions prior to 1.8b2, update to version 1.8b2 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾