PT-2015-5981
CVE-2015-2931
·
Publicado
2015-04-09
·
Atualizado
2016-12-07
Descrição por
CVSS 2.0
4.3
MédiaMétricasAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions prior to 1.19.24
MediaWiki versions 1.20.x through 1.23.9
MediaWiki versions 1.24.x prior to 1.24.2
Description
The issue allows remote attackers to inject arbitrary web script or HTML via an application/xml MIME type for a nested SVG with a data: URI. This is due to an incomplete blacklist vulnerability in includes/upload/UploadBase.php.
Recommendations
For MediaWiki versions prior to 1.19.24, update to version 1.19.24 or later.
For MediaWiki versions 1.20.x through 1.23.9, update to version 1.23.9 or later.
For MediaWiki versions 1.24.x prior to 1.24.2, update to version 1.24.2 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾