PT-2015-6085
CVE-2015-3166
·
Publicado
2015-05-22
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 9.0.20
PostgreSQL versions 9.1.x prior to 9.1.16
PostgreSQL versions 9.2.x prior to 9.2.11
PostgreSQL versions 9.3.x prior to 9.3.7
PostgreSQL versions 9.4.x prior to 9.4.2
Description
The issue is related to the snprintf implementation, which does not properly handle system-call errors. This can allow attackers to obtain sensitive information or have other unspecified impact via unknown vectors, such as an out-of-memory error.
Recommendations
For versions prior to 9.0.20, update to version 9.0.20 or later.
For versions 9.1.x prior to 9.1.16, update to version 9.1.16 or later.
For versions 9.2.x prior to 9.2.11, update to version 9.2.11 or later.
For versions 9.3.x prior to 9.3.7, update to version 9.3.7 or later.
For versions 9.4.x prior to 9.4.2, update to version 9.4.2 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾