PT-2015-7563
CVE-2015-7545
·
Publicado
2015-12-08
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Git versions prior to 2.3.10
Git versions 2.4.x prior to 2.4.10
Git versions 2.5.x prior to 2.5.4
Git versions 2.6.x prior to 2.6.1
Description
The issue is related to the git-remote-ext and other remote helper programs in Git, which do not properly restrict allowed protocols. This might allow remote attackers to execute arbitrary code via a URL in a .gitmodules file or other sources in a submodule.
Recommendations
For Git versions prior to 2.3.10, update to version 2.3.10 or later.
For Git versions 2.4.x prior to 2.4.10, update to version 2.4.10 or later.
For Git versions 2.5.x prior to 2.5.4, update to version 2.5.4 or later.
For Git versions 2.6.x prior to 2.6.1, update to version 2.6.1 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾