PT-2016-1671
CVE-2016-0785
·
Publicado
2016-04-12
·
Atualizado
2022-05-14
Descrição por
CVSS 2.0
10
AltaMétricasAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apache Struts versions prior to 2.3.28
Apache Struts 2.x before 2.3.20.3
Apache Struts 2.x before 2.3.24.3
Description
The issue allows remote attackers to execute arbitrary code via a `%{}" sequence in a tag attribute, also known as forced double OGNL evaluation. This is due to insufficient input validation in the Apache Struts platform.
Recommendations
For versions prior to 2.3.20.3, update to version 2.3.20.3 or later.
For versions prior to 2.3.24.3, update to version 2.3.24.3 or later.
For versions prior to 2.3.28, update to version 2.3.28 or later.
As a temporary workaround, consider restricting the use of the
%{} sequence in tag attributes to minimize the risk of exploitation.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾