PT-2016-2023
CVE-2015-4116
·
Publicado
2016-05-16
·
Atualizado
2018-10-30
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.5.27
PHP versions 5.6.x prior to 5.6.11
Description
The issue is related to a use-after-free vulnerability in the
spl ptr heap insert function, which can be exploited by remote attackers to execute arbitrary code. This is achieved by triggering a failed SplMinHeap::compare operation, allowing for the execution of arbitrary code.Recommendations
For PHP versions prior to 5.5.27, update to version 5.5.27 or later.
For PHP versions 5.6.x prior to 5.6.11, update to version 5.6.11 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾