PT-2016-2030

CVE-2016-1835

·

Publicado

2016-05-20

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
8.8
Alta
MétricasAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions libxml2 versions prior to 2.9.4 Apple iOS versions prior to 9.3.2 Apple OS X versions prior to 10.11.5
Description The issue is caused by a buffer overflow in the libxml2 library, which can be exploited by a remote attacker using a specially crafted XML document. This can lead to arbitrary code execution or a denial of service (memory corruption). The vulnerability is also described as a use-after-free issue in the xmlSAX2AttributeNs function, allowing remote attackers to cause a denial of service via a crafted XML document.
Recommendations For libxml2 versions prior to 2.9.4, update to version 2.9.4 or later to resolve the issue. For Apple iOS versions prior to 9.3.2, update to version 9.3.2 or later to resolve the issue. For Apple OS X versions prior to 10.11.5, update to version 10.11.5 or later to resolve the issue. As a temporary workaround, consider restricting the use of the xmlSAX2AttributeNs function until a patch is available. Avoid using specially crafted XML documents that could exploit the buffer overflow vulnerability.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2017-1240
CESA-2016_1292
DLA-503-1
DSA-3593-1
ECHO-3F27-7D6C-7C08
MGASA-2016-0263
OPENSUSE-SU-2016_1594-1
OPENSUSE-SU-2016_1595-1
OPENSUSE-SU-2024:10192-1
OPENSUSE-SU-2024:10228-1
RHSA-2016:1292
RHSA-2016_1292
SUSE-SU-2016:1538-1
SUSE-SU-2016:1604-1
SUSE-SU-2017:2699-1
SUSE-SU-2017:2700-1
USN-2994-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾