PT-2016-2300
CVE-2016-4465
·
Publicado
2016-07-04
·
Atualizado
2022-05-17
Descrição por
CVSS 3.1
5.3
MédiaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
Apache Struts versions 2.3.20 through 2.3.28.1
Apache Struts versions 2.5.x before 2.5.13
Description
The issue exists due to insufficient input validation in the URLValidator class of Apache Struts. This allows a remote attacker to cause a denial of service by providing a null value for a URL field.
Recommendations
For Apache Struts versions 2.3.20 through 2.3.28.1, update to a version outside of this range to resolve the issue.
For Apache Struts versions 2.5.x before 2.5.13, update to version 2.5.13 or later to resolve the issue.
As a temporary workaround, consider restricting the input for URL fields to prevent null values from being processed by the URLValidator class.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾