PT-2016-3100
CVE-2016-10167
·
Publicado
2016-12-31
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
5.5
MédiaMétricasAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
GD Graphics Library versions prior to 2.2.4
Description
The issue is caused by an integer overflow in the gd io.c component of the GD Graphics Library. This can be exploited by a remote attacker to potentially cause undefined impact by manipulating the number of horizontal and vertical elements in an image. The gdImageCreateFromGd2Ctx function in gd gd2.c is also affected, allowing remote attackers to cause a denial of service via a crafted image file.
Recommendations
For versions prior to 2.2.4, update to version 2.2.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the gdImageCreateFromGd2Ctx function until a patch is applied. Avoid using the vulnerable component of the GD Graphics Library with untrusted image files until the issue is resolved.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾