PT-2016-3368

CVE-2016-7130

·

Publicado

2016-09-11

·

Atualizado

2018-01-05

Descrição por

CVSS 2.0
7.8
Alta
MétricasAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.25 PHP versions 7.x prior to 7.0.10
Description The issue is related to the php wddx pop element function, which can cause a denial of service due to a NULL pointer dereference and application crash when handling an invalid base64 binary value. This can be triggered by a wddx deserialize call that mishandles a binary element in a wddxPacket XML document. The vulnerability may allow remote attackers to have unspecified other impact.
Recommendations For PHP versions prior to 5.6.25, update to version 5.6.25 or later. For PHP versions 7.x prior to 7.0.10, update to version 7.0.10 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
DLA-749-1
DSA-3689-1
OPENSUSE-SU-2016_2337-1
OPENSUSE-SU-2016_2451-1
RHSA-2016:2750
SUSE-SU-2016:2328-1
SUSE-SU-2016:2408-1
SUSE-SU-2016:2459-1
SUSE-SU-2016:2460-1
SUSE-SU-2016:2460-2
USN-3095-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾