PT-2016-3369
CVE-2016-7129
·
Publicado
2016-09-11
·
Atualizado
2018-01-05
Descrição por
CVSS 2.0
10
CríticaMétricasAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.25
PHP versions 7.x prior to 7.0.10
Description
The issue is related to the
php wddx process data function, which does not properly check input data. This can be exploited by remote attackers to cause a denial of service, potentially resulting in a segmentation fault, by providing an invalid ISO 8601 time value. This can be demonstrated through a wddx deserialize call that mishandles a dateTime element in a wddxPacket XML document.Recommendations
For PHP versions prior to 5.6.25, update to version 5.6.25 or later.
For PHP versions 7.x prior to 7.0.10, update to version 7.0.10 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾