PT-2016-3402
CVE-2016-5771
·
Publicado
2016-06-24
·
Atualizado
2022-07-20
Descrição por
CVSS 3.1
10
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.5.37
PHP versions 5.6.x prior to 5.6.23
Description
The issue is related to improper interaction between the SPL extension and the unserialize implementation, along with garbage collection. This can be exploited by remote attackers using crafted serialized data, potentially leading to the execution of arbitrary code or a denial of service, resulting in a use-after-free condition and application crash.
Recommendations
For PHP versions prior to 5.5.37, update to version 5.5.37 or later.
For PHP versions 5.6.x prior to 5.6.23, update to version 5.6.23 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾