PT-2016-4017
CVE-2015-8779
·
Publicado
2016-02-16
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
glibc versions prior to 2.23
Description
The issue is related to a stack-based buffer overflow in the catopen function, which can be exploited by context-dependent attackers. This can lead to a denial of service, causing the application to crash, or potentially allow the execution of arbitrary code if a long catalog name is used.
Recommendations
For versions prior to 2.23, update to version 2.23 or later to resolve the issue. As a temporary workaround, consider restricting the length of catalog names to prevent exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾