PT-2016-5047

CVE-2016-2174

·

Publicado

2016-06-13

·

Atualizado

2018-10-17

Descrição por

CVSS 3.1
7.2
Alta
MétricasAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Ranger versions prior to 0.5.3
Description The issue allows remote authenticated administrators to execute arbitrary SQL commands. This is achieved by exploiting the eventTime parameter in the /service/plugins/policies/eventTime API endpoint.
Recommendations For versions prior to 0.5.3, update to version 0.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the /service/plugins/policies/eventTime API endpoint to minimize the risk of exploitation. Avoid using the eventTime parameter in the affected API endpoint until the issue is resolved.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-4RJF-MXFM-98H5
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾