PT-2016-5121

CVE-2016-2342

·

Publicado

2015-03-07

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
8.1
Alta
MétricasAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Quagga versions prior to 1.0.20160309
Description The issue arises from the bgp nlri parse vpnv4 function in bgp mplsvpn.c within the VPNv4 NLRI parser in bgpd when a specific VPNv4 configuration is used. It relies on a Labeled-VPN SAFI routes-data length field during a data copy, allowing remote attackers to execute arbitrary code or cause a denial of service through a crafted packet, resulting in a stack-based buffer overflow.
Recommendations For versions prior to 1.0.20160309, update to version 1.0.20160309 or later to resolve the issue. As a temporary workaround, consider restricting the use of the VPNv4 configuration that triggers this issue until a patch is applied.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2015-1266
CESA-2017_0794
DSA-3532-1
MGASA-2016-0126
OPENSUSE-SU-2024:10362-1
RHSA-2017:0794
RHSA-2017_0794
SUSE-SU-2016:0936-1
SUSE-SU-2016_0936-1
SUSE-SU-2016:0946-1
SUSE-SU-2016_0946-1
USN-2941-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾