PT-2016-5191
CVE-2016-2533
·
Publicado
2016-02-28
·
Atualizado
2020-05-06
Descrição por
CVSS 4.0
7.1
AltaMétricasAV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Pillow versions prior to 3.1.1
Python Imaging Library (PIL) version 1.1.7 and earlier
Description
The issue is related to a buffer overflow in the
ImagingPcdDecode function, which can be triggered by a crafted PhotoCD file, allowing remote attackers to cause a denial of service (crash).Recommendations
For Pillow versions prior to 3.1.1, update to version 3.1.1 or later to resolve the issue.
For Python Imaging Library (PIL) version 1.1.7 and earlier, update to a version later than 1.1.7 to resolve the issue.
As a temporary workaround, consider disabling the use of the
ImagingPcdDecode function in PcdDecode.c until a patch is available.Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾