PT-2016-6420

CVE-2016-5423

·

Publicado

2016-08-11

·

Atualizado

2024-06-15

Descrição por

CVSS 3.1
8.3
Alta
MétricasAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 9.1.23 PostgreSQL versions 9.2.x prior to 9.2.18 PostgreSQL versions 9.3.x prior to 9.3.14 PostgreSQL versions 9.4.x prior to 9.4.9 PostgreSQL versions 9.5.x prior to 9.5.4
Description The issue allows remote authenticated users to cause a denial of service, obtain sensitive memory information, or possibly execute arbitrary code. This can be achieved through a CASE expression within the test value subexpression of another CASE or inlining of an SQL function that implements the equality operator used for a CASE expression involving values of different types. Certain nested CASE/WHEN expressions can also crash the server.
Recommendations For PostgreSQL versions prior to 9.1.23, update to version 9.1.23 or later. For PostgreSQL versions 9.2.x prior to 9.2.18, update to version 9.2.18 or later. For PostgreSQL versions 9.3.x prior to 9.3.14, update to version 9.3.14 or later. For PostgreSQL versions 9.4.x prior to 9.4.9, update to version 9.4.9 or later. For PostgreSQL versions 9.5.x prior to 9.5.4, update to version 9.5.4 or later. As a temporary workaround, consider avoiding the use of nested CASE/WHEN expressions until a patch is applied.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
CESA-2016_2606
DLA-592-1
DSA-3646-1
MGASA-2016-0289
OPENSUSE-SU-2016_2425-1
OPENSUSE-SU-2016_2464-1
OPENSUSE-SU-2017_1021-1
OPENSUSE-SU-2024:10030-1
OPENSUSE-SU-2024:10256-1
OPENSUSE-SU-2024:10273-1
RHSA-2016:1781
RHSA-2016:1820
RHSA-2016:1821
RHSA-2016:2606
RHSA-2016_2606
RHSA-2017:2425
SUSE-SU-2016:2414-1
SUSE-SU-2016_2414-1
SUSE-SU-2016:2415-1
SUSE-SU-2016_2415-1
SUSE-SU-2016:2418-1
SUSE-SU-2016_2418-1
USN-3066-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾