PT-2016-7322
CVE-2016-7425
·
Publicado
2016-10-16
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
7.8
AltaMétricasAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.8.3
Description
The issue allows local users to gain privileges or cause a denial of service due to a heap-based buffer overflow. This is caused by the
arcmsr iop message xfer function in drivers/scsi/arcmsr/arcmsr hba.c not restricting a certain length field, which can be exploited via an ARCMSR MESSAGE WRITE WQBUFFER control code.Recommendations
For Linux kernel versions prior to 4.8.3, update to version 4.8.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the
arcmsr iop message xfer function until a patch is available.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾