PT-2016-7442
CVE-2016-7949
·
Publicado
2016-10-12
·
Atualizado
2022-05-23
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libXrender versions prior to 0.9.10
Description
The issue involves multiple buffer overflows in the XvQueryAdaptors and XvQueryEncodings functions. These buffer overflows can be triggered by remote X servers via vectors involving length fields, allowing out-of-bounds write operations.
Recommendations
For libXrender versions prior to 0.9.10, update to version 0.9.10 or later to resolve the issue. As a temporary workaround, consider restricting access to the XvQueryAdaptors and XvQueryEncodings functions until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾