PT-2017-10390
CVE-2016-9933
·
Publicado
2016-12-13
·
Atualizado
2018-05-04
Descrição por
CVSS 3.1
7.5
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
GD Graphics Library versions prior to 2.2.2
PHP versions prior to 5.6.28 and 7.x prior to 7.0.13
Description
The issue is related to a stack consumption vulnerability in the
gdImageFillToBorder function. This vulnerability can be exploited by remote attackers to cause a denial of service, resulting in a segmentation violation. The exploitation occurs when a crafted imagefilltoborder call is made, triggering the use of a negative color value.Recommendations
For GD Graphics Library versions prior to 2.2.2, update to version 2.2.2 or later.
For PHP versions prior to 5.6.28, update to version 5.6.28 or later.
For PHP 7.x versions prior to 7.0.13, update to version 7.0.13 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾