PT-2017-10699
CVE-2017-0898
·
Publicado
2017-09-15
·
Atualizado
2026-09-18
Descrição por
CVSS 3.1
9.1
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Ruby versions prior to 2.4.2
Ruby versions prior to 2.3.5
Ruby versions prior to 2.2.8
Description
The issue is related to malicious format strings containing a precious specifier (*) with a huge minus value, which can lead to a buffer overrun. This situation may result in heap memory corruption or information disclosure from the heap.
Recommendations
For versions prior to 2.4.2, update to version 2.4.2 or later.
For versions prior to 2.3.5, update to version 2.3.5 or later.
For versions prior to 2.2.8, update to version 2.2.8 or later.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾