PT-2017-10700
CVE-2017-0899
·
Publicado
2017-08-31
·
Atualizado
2026-09-18
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RubyGems versions 2.6.12 and earlier
Description
The issue allows maliciously crafted gem specifications that include terminal escape characters to execute terminal escape sequences when the gem specification is printed. This could potentially lead to unintended consequences.
Recommendations
For RubyGems versions 2.6.12 and earlier, update to version 2.6.13 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾