PT-2017-10906

CVE-2017-1000208

·

Publicado

2017-11-17

·

Atualizado

2019-10-03

Descrição por

CVSS 3.1
8.8
Alta
MétricasAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Swagger-Parser versions <= 1.0.30 swagger-codegen versions <= 2.2.2
Description A vulnerability in Swagger-Parser's yaml parsing functionality can result in arbitrary code execution when a maliciously crafted yaml Open-API specification is parsed. This affects the 'generate' and 'validate' commands in swagger-codegen, potentially leading to arbitrary code execution when these commands are used on a well-crafted yaml specification.
Recommendations For Swagger-Parser versions <= 1.0.30, update to a version greater than 1.0.30 to resolve the issue. For swagger-codegen versions <= 2.2.2, update to a version greater than 2.2.2 to resolve the issue. As a temporary workaround, consider restricting the use of the 'generate' and 'validate' commands in swagger-codegen until a patch is available.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-Q7PF-QR96-2VQ5
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾