PT-2017-12044
CVE-2017-11480
·
Publicado
2017-12-08
·
Atualizado
2022-02-15
Descrição por
CVSS 3.1
7.5
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Packetbeat versions prior to 5.6.4
Packetbeat version 6.0.0
Description
The issue is a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic. A local attacker can cause a panic due to an out of bounds read if they are able to send arbitrary traffic to a monitored port.
Recommendations
For Packetbeat versions prior to 5.6.4, update to version 5.6.4 or later to resolve the issue.
For Packetbeat version 6.0.0, update to a version later than 6.0.0 to resolve the issue.
As a temporary workaround, consider restricting access to the monitored port to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾