PT-2017-14397

CVE-2017-16384

·

Publicado

2017-11-14

·

Atualizado

2019-10-03

Descrição por

CVSS 2.0
9.3
Alta
MétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Adobe Acrobat and Reader versions 2017.012.20098 and earlier Adobe Acrobat and Reader versions 2017.011.30066 and earlier Adobe Acrobat and Reader versions 2015.006.30355 and earlier Adobe Acrobat and Reader versions 11.0.22 and earlier
Description The issue is caused by a buffer over-read in the exif processing module for a PNG file during XPS conversion. Invalid input leads to a computation where pointer arithmetic results in a location outside valid memory locations belonging to the buffer. This can be used to obtain sensitive information, such as object heap addresses. Additionally, it allows attackers to execute code remotely.
Recommendations For versions 2017.012.20098 and earlier, update to a version later than 2017.012.20098 to resolve the issue. For versions 2017.011.30066 and earlier, update to a version later than 2017.011.30066 to resolve the issue. For versions 2015.006.30355 and earlier, update to a version later than 2015.006.30355 to resolve the issue. For versions 11.0.22 and earlier, update to a version later than 11.0.22 to resolve the issue. As a temporary workaround, consider restricting the use of the exif processing module for PNG files during XPS conversion until a patch is available.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
ZDI-17-901
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾