PT-2017-1549
CVE-2016-10058
·
Publicado
2017-03-23
·
Atualizado
2020-11-16
Descrição por
CVSS 2.0
7.1
AltaMétricasAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
ImageMagick versions prior to 6.9.6-3
Description
The issue is related to a memory leak in the
ReadPSDLayers function. This can be exploited by a remote attacker using a specially crafted image file, potentially leading to a denial of service due to memory consumption.Recommendations
For versions prior to 6.9.6-3, update to version 6.9.6-3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
ReadPSDLayers function in the coders/psd.c file until a patch is applied.Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾