PT-2017-15551

CVE-2017-2809

·

Publicado

2017-09-14

·

Atualizado

2022-04-19

Descrição por

CVSS 4.0
8.5
Alta
MétricasAV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions ansible-vault versions prior to 1.0.5
Description The issue concerns the yaml loading functionality, where a specially crafted vault can execute arbitrary python commands, resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.
Recommendations For versions prior to 1.0.5, update to version 1.0.5 or later to resolve the issue.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-C2W9-48QC-QPJ4
PYSEC-2017-5
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾