PT-2017-16556

CVE-2017-5522

·

Publicado

2017-01-19

·

Atualizado

2021-06-07

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions MapServer versions prior to 6.0.6 MapServer versions 6.2.x prior to 6.2.4 MapServer versions 6.4.x prior to 6.4.5 MapServer versions 7.0.x prior to 7.0.4
Description The issue is a stack-based buffer overflow that can be triggered by remote attackers through vectors involving WFS get feature requests, potentially leading to a denial of service (crash) or the execution of arbitrary code.
Recommendations For MapServer versions prior to 6.0.6, update to version 6.0.6 or later. For MapServer versions 6.2.x prior to 6.2.4, update to version 6.2.4 or later. For MapServer versions 6.4.x prior to 6.4.5, update to version 6.4.5 or later. For MapServer versions 7.0.x prior to 7.0.4, update to version 7.0.4 or later.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
DLA-790-1
DSA-3766-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾