PT-2017-16736
CVE-2017-5885
·
Publicado
2017-02-07
·
Atualizado
2024-06-15
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
gtk-vnc versions prior to 0.7.0
Description
The issue is related to multiple integer overflows in the
vnc connection server message and vnc color map set functions. These overflows can be triggered by remote servers via vectors involving SetColorMapEntries, potentially leading to a buffer overflow. This could cause a denial of service (crash) or possibly allow the execution of arbitrary code.Recommendations
For versions prior to 0.7.0, update to version 0.7.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the
vnc connection server message and vnc color map set functions until a patch is available.Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾