PT-2017-1737

CVE-2016-10060

·

Publicado

2016-06-05

·

Atualizado

2021-04-28

Descrição por

CVSS 3.1
6.5
Média
MétricasAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions prior to 7.0.1-10
Description The issue exists due to insufficient input validation in the ConcatenateImages function. This allows a remote attacker to cause a denial of service, resulting in the application crashing, by using a specially crafted file. The vulnerability is related to the lack of return value checking for the fputc function.
Recommendations For versions prior to 7.0.1-10, update to version 7.0.1-10 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ConcatenateImages function until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2016-1580
DLA-756-1
SUSE-SU-2017:0529-1
SUSE-SU-2017:0586-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾