PT-2017-1979
CVE-2007-6761
·
Publicado
2017-04-24
·
Atualizado
2017-04-27
Descrição por
CVSS 3.1
7.8
AltaMétricasAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 2.6.24
Description
The issue is caused by a buffer overflow in the videobuf-vmalloc.c driver, specifically in the videobuf mapping data structures. This can be exploited by a local attacker to cause incorrect numerical values and a videobuf leak. The exploitation is possible due to the lack of initialization of videobuf mapping data structures.
Recommendations
For Linux kernel versions prior to 2.6.24, update to version 2.6.24 or later to resolve the issue. As a temporary workaround, consider restricting access to the videobuf-vmalloc.c driver to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾