PT-2017-2111

CVE-2016-2173

·

Publicado

2017-04-21

·

Atualizado

2022-05-13

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Spring AMQP versions prior to 1.5.5
Description The issue is related to insufficient input validation in the org.springframework.core.serializer.DefaultDeserializer component of the Spring AMQP application for RabbitMQ message exchange. This allows a remote attacker to execute arbitrary code.
Recommendations For versions prior to 1.5.5, update to version 1.5.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the DefaultDeserializer component to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
GHSA-HRP3-8P5W-27GV
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾