PT-2017-2280
CVE-2017-2518
·
Publicado
2017-05-22
·
Atualizado
2021-09-23
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
iOS versions prior to 10.3.2
macOS versions prior to 10.12.5
tvOS versions prior to 10.2.1
watchOS versions prior to 3.2.2
Description
The issue involves the
SQLite component and allows remote attackers to execute arbitrary code or cause a denial of service via a crafted SQL statement. This can result in a buffer overflow and application crash. The vulnerability is caused by a buffer overflow in memory, which can be exploited by a specially crafted SQL query, potentially leading to arbitrary code execution or a denial of service.Recommendations
For iOS versions prior to 10.3.2, update to version 10.3.2 or later.
For macOS versions prior to 10.12.5, update to version 10.12.5 or later.
For tvOS versions prior to 10.2.1, update to version 10.2.1 or later.
For watchOS versions prior to 3.2.2, update to version 3.2.2 or later.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾