PT-2017-2559

CVE-2017-9462

·

Publicado

2017-06-06

·

Atualizado

2020-02-05

Descrição por

CVSS 2.0
9.0
Alta
MétricasAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Mercurial versions prior to 4.1.3
Description The issue is related to insufficient access control in Mercurial, specifically with the use of the command line parameter "hg serve --stdio". This can be exploited by a remote authenticated user to execute arbitrary code by using "--debugger" as a repository name, thereby launching the Python debugger.
Recommendations For Mercurial versions prior to 4.1.3, update to version 4.1.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the "hg serve --stdio" command to prevent potential exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-GHJX-3JG5-H6R2
ALT-PU-2018-2508
CESA-2017_1576
DLA-1005-1
DLA-1414-1
DSA-3963-1
MGASA-2017-0182
OPENSUSE-SU-2017_1572-1
PYSEC-2017-91
RHSA-2017:1576
RHSA-2017_1576
SUSE-SU-2017:1558-1
SUSE-SU-2017_1558-1
SUSE-SU-2017:1606-1
SUSE-SU-2017_1606-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾