PT-2017-2767
CVE-2017-12933
·
Publicado
2017-02-16
·
Atualizado
2019-10-03
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.31
PHP versions 7.0.x prior to 7.0.21
PHP versions 7.1.x prior to 7.1.7
Description
The issue is related to the
finish nested data function in the ext/standard/var unserializer.re file of the PHP interpreter. It is caused by a buffer over-read operation when unserializing untrusted data. This can allow a remote attacker to have an unspecified impact on the integrity of PHP data.Recommendations
For PHP versions prior to 5.6.31, update to version 5.6.31 or later.
For PHP versions 7.0.x prior to 7.0.21, update to version 7.0.21 or later.
For PHP versions 7.1.x prior to 7.1.7, update to version 7.1.7 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾