PT-2017-2778
CVE-2017-7548
·
Publicado
2017-05-04
·
Atualizado
2026-09-18
Descrição por
CVSS 3.1
7.5
AltaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 9.4.13
PostgreSQL versions prior to 9.5.8
PostgreSQL versions prior to 9.6.4
Description
The issue is caused by a flaw in the authorization procedure, allowing remote authenticated attackers with no privileges on a large object to overwrite its entire contents. This results in a denial of service. The
lo put() function is specifically mentioned as ignoring ACLs, contributing to the vulnerability.Recommendations
For versions prior to 9.4.13, update to version 9.4.13 or later.
For versions prior to 9.5.8, update to version 9.5.8 or later.
For versions prior to 9.6.4, update to version 9.6.4 or later.
As a temporary workaround, consider restricting access to the
lo put() function until a patch is available.Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾