PT-2017-2785
CVE-2017-10661
·
Publicado
2017-02-10
·
Atualizado
2026-10-21
Descrição por
CVSS 2.0
7.6
AltaMétricasAV:N/AC:H/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.10.15
Description
The issue is related to a race condition in the fs/timerfd.c component of the Linux kernel, which can be exploited by local users through simultaneous file-descriptor operations. This can lead to privilege escalation or a denial of service, resulting in list corruption or use-after-free. The vulnerability is associated with improper might cancel queueing.
Recommendations
For Linux kernel versions prior to 4.10.15, update to version 4.10.15 or later to resolve the issue. As a temporary workaround, consider restricting simultaneous file-descriptor operations to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾