PT-2017-2894

CVE-2017-14064

·

Publicado

2017-08-31

·

Atualizado

2026-09-18

Descrição por

CVSS 3.1
9.8
Crítica
MétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Ruby versions prior to 2.2.8 Ruby versions 2.3.x through 2.3.4 Ruby versions 2.4.x through 2.4.1
Description The issue lies in the use of strdup in ext/json/ext/generator/generator.c, which stops after encountering a 0 byte, returning a pointer to a string of length zero, not the length stored in space len. This can expose arbitrary memory during a JSON.generate call, potentially allowing a remote attacker to cause a denial of service.
Recommendations For Ruby versions prior to 2.2.8, update to version 2.2.8 or later. For Ruby versions 2.3.x through 2.3.4, update to version 2.3.5 or later. For Ruby versions 2.4.x through 2.4.1, update to version 2.4.2 or later. As a temporary workaround, consider restricting the use of the JSON.generate call until a patch is available.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2017-2216
CESA-2018_0378
CLEANSTART-2026-DS52341
DLA-1114-1
DLA-1421-1
DSA-3966-1
MGASA-2017-0371
RHSA-2017:3485
RHSA-2018:0378
RHSA-2018_0378
RHSA-2018:0583
RHSA-2018:0585
RHSA-2026:7305
RHSA-2026:7307
RHSA-2026:8838
SUSE-SU-2020:1570-1
SUSE-SU-2020_1570-1
USN-3439-1
USN-3528-1
USN-3685-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾