PT-2017-3307
CVE-2017-16643
·
Publicado
2017-10-27
·
Atualizado
2018-08-24
Descrição por
CVSS 2.0
7.2
AltaMétricasAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.13.11
Description
The issue is related to the
parse hid report descriptor function in the Linux kernel, which allows local users to cause a denial of service or possibly have other impacts via a crafted USB device. This is due to an out-of-bounds read in memory, potentially leading to a system crash. The exploitation of this issue may allow an attacker to cause unspecified other impacts, including reading beyond memory boundaries.Recommendations
For Linux kernel versions prior to 4.13.11, update to version 4.13.11 or later to resolve the issue. As a temporary workaround, consider restricting the use of USB devices from untrusted sources to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾