PT-2017-3432

CVE-2017-12608

·

Publicado

2017-10-26

·

Atualizado

2022-02-07

Descrição por

CVSS 3.1
7.8
Alta
MétricasAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache OpenOffice versions prior to 4.1.4
Description The issue is related to a buffer overflow in the ImportOldFormatStyles function of the DOC file parser, allowing attackers to craft malicious documents. This can cause denial of service, including memory corruption and application crash, and potentially result in arbitrary code execution.
Recommendations For versions prior to 4.1.4, update to version 4.1.4 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the ImportOldFormatStyles function until a patch is available. Restrict access to potentially malicious DOC files to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Enumeração de fraquezas
Identificadores relacionados
DLA-1214-1
DSA-4022-1
USN-3472-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾