PT-2017-4178

CVE-2017-11628

·

Publicado

2017-07-08

·

Atualizado

2018-05-04

Descrição por

CVSS 2.0
9.3
Alta
MétricasAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.31 PHP versions 7.x prior to 7.0.21 PHP versions 7.1.x prior to 7.1.7
Description A stack-based buffer overflow in the zend ini do op() function could cause a denial of service or potentially allow executing code. This issue is relevant for PHP applications that accept untrusted input for the parse ini string or parse ini file function.
Recommendations For PHP versions prior to 5.6.31, update to version 5.6.31 or later. For PHP versions 7.x prior to 7.0.21, update to version 7.0.21 or later. For PHP versions 7.1.x prior to 7.1.7, update to version 7.1.7 or later. As a temporary workaround, consider restricting the use of the parse ini string and parse ini file functions to trusted input only, until a patch is available.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2017-1822
DLA-1066-1
DSA-4080-1
DSA-4081-1
OPENSUSE-SU-2017_2337-1
RHSA-2018:1296
SUSE-SU-2017:2303-1
SUSE-SU-2017:2317-1
SUSE-SU-2017:2522-1
USN-3382-1
USN-3382-2
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾