PT-2017-4185
CVE-2016-10158
·
Publicado
2017-01-24
·
Atualizado
2018-05-04
Descrição por
CVSS 2.0
7.8
AltaMétricasAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.30
PHP versions 7.0.x prior to 7.0.15
PHP versions 7.1.x prior to 7.1.1
Description
The issue is related to errors in number processing in the
exif convert any to int function. This can be exploited by remote attackers to cause a denial of service (application crash) via crafted EXIF data. The exploitation is possible due to an attempt to divide the minimum representable negative integer by -1.Recommendations
For PHP versions prior to 5.6.30, update to version 5.6.30 or later.
For PHP versions 7.0.x prior to 7.0.15, update to version 7.0.15 or later.
For PHP versions 7.1.x prior to 7.1.1, update to version 7.1.1 or later.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾