PT-2017-4214
CVE-2017-16910
·
Publicado
2017-11-21
·
Atualizado
2022-01-29
Descrição por
CVSS 2.0
7.1
AltaMétricasAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
LibRaw versions prior to 0.18.6
Description
The issue is related to a buffer data boundary read in the internal/dcraw common.cpp component of the LibRaw image processing library. It allows a remote attacker to cause a Denial of Service condition by exploiting an error within the
LibRaw::xtrans interpolate() function.Recommendations
For versions prior to 0.18.6, update to version 0.18.6 or later to resolve the issue.
As a temporary workaround, consider restricting access to the
LibRaw::xtrans interpolate() function until a patch is available.Explorabilidade
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾