PT-2017-6795
CVE-2015-4706
·
Publicado
2015-08-08
·
Atualizado
2022-05-17
Descrição por
CVSS 4.0
5.3
MédiaMétricasAV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Name of the Vulnerable Software and Affected Versions
IPython versions prior to 3.2
Description
A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the "api/contents" path.
Recommendations
For IPython versions prior to 3.2, update to version 3.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the "api/contents" path to minimize the risk of exploitation.
Explorabilidade
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾