PT-2017-7456
CVE-2015-8626
·
Publicado
2015-12-24
·
Atualizado
2017-08-22
Descrição por
CVSS 3.1
9.8
CríticaMétricasAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
MediaWiki versions prior to 1.23.12
MediaWiki versions 1.24.x prior to 1.24.5
MediaWiki versions 1.25.x prior to 1.25.4
MediaWiki versions 1.26.x prior to 1.26.1
Description
The issue allows remote attackers to obtain access via a brute-force attack due to the generation of passwords smaller than the minimal required length. This is caused by the
User::randomPassword function.Recommendations
For MediaWiki versions prior to 1.23.12, update to version 1.23.12 or later.
For MediaWiki versions 1.24.x prior to 1.24.5, update to version 1.24.5 or later.
For MediaWiki versions 1.25.x prior to 1.25.4, update to version 1.25.4 or later.
For MediaWiki versions 1.26.x prior to 1.26.1, update to version 1.26.1 or later.
Explorabilidade
Exploit
Correção
Pesquisadores
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾