PT-2017-8715

CVE-2016-5394

·

Publicado

2017-07-19

·

Atualizado

2022-05-13

Descrição por

CVSS 3.1
6.1
Média
MétricasAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12
Description The issue arises from the XSS Protection API module, where the encoding performed by the XSSAPI.encodeForJSString() method is not restrictive enough. This allows script tags to pass through unencoded for certain input patterns, potentially leading to XSS vulnerabilities.
Recommendations For versions prior to 1.0.12, update to version 1.0.12 or later to resolve the issue. As a temporary workaround, consider restricting the use of the XSSAPI.encodeForJSString() method until a patch is applied.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Identificadores relacionados
GHSA-XWF4-88XR-HX2J
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾