PT-2018-10170

CVE-2018-10900

·

Publicado

2018-07-23

·

Atualizado

2020-12-04

Descrição por

CVSS 3.1
8.8
Alta
MétricasAV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Network Manager VPNC plugin versions prior to 1.2.6
Description The issue allows for a privilege escalation attack. An attacker can inject a Password helper parameter into the configuration data passed to VPNC by using a new line character, enabling the execution of arbitrary commands as root.
Recommendations For versions prior to 1.2.6, update to version 1.2.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the VPNC plugin to minimize the risk of exploitation.
Explorabilidade
Exploit
Correção
Impactos
Pesquisadores
Fornecedores
Produtos afetados
Identificadores relacionados
ALT-PU-2018-2074
DLA-1454-1
DSA-4253-1
OPENSUSE-SU-2018_2307-1
OPENSUSE-SU-2024:10604-1
SUSE-SU-2018:2297-1
SUSE-SU-2018_2297-1
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾