PT-2018-11100
CVE-2018-12293
·
Publicado
2018-06-12
·
Atualizado
2020-08-24
Descrição por
CVSS 3.1
8.8
AltaMétricasAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WebKitGTK+ versions prior to 2.20.3
WPE WebKit versions prior to 2.20.1
Description
The issue is related to a heap-based buffer overflow in the getImageData function within the ImageBufferCairo class. This overflow is triggered by an integer overflow and can be exploited by crafted HTML content.
Recommendations
For WebKitGTK+ versions prior to 2.20.3, update to version 2.20.3 or later.
For WPE WebKit versions prior to 2.20.1, update to version 2.20.1 or later.
Explorabilidade
Exploit
Correção
Impactos
Fornecedores
Produtos afetados
Encontrou algum problema na descrição? Tem algo a acrescentar? Fique à vontade para nos escrever 👾